Reposting this here: Stuck on Reconnect button after Champion select, cant get into Game

https://boards.na.leagueoflegends.com/en/c/bug-report/wkFphhmw-stuck-on-this-hellish-reconnect-button Stuck on this hellish Reconnect Button!!! I have a LPQ, and I wondered why I had that. Now I know. Its because of this RECONNECT BUTTON For some reason, (1). every time Champion Select ends and the game is about to boot up, It flashes "Game Still in Progress" for about 0.8 seconds and then reverts to this "Reconnect" button. (2). Every time I click the "Reconnect" button, it does not enter the game or reconnect, but repeats (1) I think I may have quit this game months ago because I had this issue and there were no clear solutions. Even though I havent actually connected it still counts me as AFK and I am probably going to have a LPQ again. This is EXTREMELY FRUSTRATING because it basically means I have to wait 20+ minutes to see if something I've done has fixed the connection issue! Its rubbish! But on topic, is there any way to fix this? I have a MacBook Air, Firewall is Off, DNS is 100% how it should be, I have no applications running that I know of besides LoL, Ive switched my ISP since last I logged in, I cleared all data including in App Support and did a fresh reinstall yet still this Reconnect Trap persists. Its so annoying. I found out that I can test the game with a custom match to avoid getting LPQ'd but nope, even in those games I still get the reconnect button limbo after champion select. Trying to play a tutorial game just greys over the "Play Game" button once you press it, and you have to restart the client. Its like it refuses to boot up the ACTUAL game for some reason, which is just weird because it worked on this very computer just fine about 10 months ago and for years before that!!! Also, another cruddy thing is that the Hextech repair tool glitches out whenever I download it, there is no text except for zeroes and I cant leave the program without force quitting. It might be a font problem, maybe, idk. When I ran it through terminal multiple errors stating "detected broken kqueue; not using.: Undefined error: 0" which was followed by : "2018-09-08 18:22:26.845 HextechRepairTool Helper[32103:70941425] XType: failed to connect - Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.fonts was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.fonts was invalidated.} 2018-09-08 18:22:26.845 HextechRepairTool Helper[32103:70941425] Font server protocol version mismatch (expected:5 got:0), falling back to local fonts 2018-09-08 18:22:26.845 HextechRepairTool Helper[32103:70941425] XType: unable to make a connection to the font daemon! 2018-09-08 18:22:26.845 HextechRepairTool Helper[32103:70941425] registering /System/Library/Fonts/*, /System/Library/Fonts/Base/*, and /Library/Fonts/* locally" Not a good sign when the repair tool itself isnt working...! If you look in my original thread, you can clearly see that many other people are stuck on the same problem and are prevented from playing the game. To my knowledge I am not running any third-party software that would mess with my connection Here are some threads over the past year both Mac and Windows who had this issue and did not get an answer back (some of them apparently fixed on their own but they dont know how): https://boards.na.leagueoflegends.com/en/c/help-support/KBW9xdRE-stuck-at-reconnect-screen https://boards.na.leagueoflegends.com/en/c/bug-report/HiyB6IEg-game-stuck-on-reconnect-screen-after-patching https://boards.na.leagueoflegends.com/en/c/help-support/LfftgMp7-stuck-at-reconnect-screen-after-champion-select-wont-let-me-join-game-after-i-click-reconnect https://boards.na.leagueoflegends.com/en/c/bug-report/F5KUiavj-canot-connect-to-games-client https://boards.oce.leagueoflegends.com/en/c/gameplay-strategy/B2UEgaL4-stuck-at-reconnect-screen https://boards.euw.leagueoflegends.com/en/c/help-support-en/1y8a35Ql-reconnect-button-appears-on-client-and-game-doesnt-start and many others Here is a Youtube video (on Windows not Mac) of someone who had the same issue: https://www.youtube.com/watch?v=knG5PJcSCUw
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel